opendict

Program opendict je alternativa k slovníku StarDict. Nabízí velké množství slovníků včetně anglicko-českého/česko-anglického slovníku. Program je vytvářen jako open-source a je multiplatformní (Linux, Mac OS X, Windows). Nabízí 50 slovníků pro různé jazyky a tyto slovníky jsou zdarma.

Program je v anglickém jazyku a zatím nevím o možném překladu do češtiny.

Instalace

Nainstalujte balíky: opendict a opendict-plugins-lingvosoft.

Spuštění

Program spustíte z nabídky Dash → Dictionary OpenDict.

Konfigurace

  • spusťte program
  • v menu Dictionaries si vyberte pro anglicko-český slovník volbu English ⇔ Czech (LingvoSoft). Tímto si nastavíte překlad slovníku na typ česko-anlický/anglicko-český.
  • obdobně si můžete vybrat i jiné jazyky přes volbu Dictionaries
  • v menu Tools → Manage dictionaries jsou dvě stránky Installed a Available
  • Installed: Tady si zakřížkujte z [] na [x] vybrané slovníky, které byste chtěli používat.
  • Available: Zmáčkněte tlačítko Update list a pak si ze seznamu vyberte slovník a nainstalujete ho stiskem tlačítka Install. Tento slovník se pak zpřístupní ve stránce Installed.
  • Volba Tools → Take Words From Clipboard aktivuje překládání slov uložených ve schránce (clipboardu). Když máte spuštěn program a zkopírujete do schránky Ctrl+C nějaký text, automaticky se Vám v programu přeloží.
  • Volba View → Font Size reguluje velikost fontu. Increase zvětšuje, Decrease zmenšuje, Normal vrácí původní velikost fontu.
  • Volba View → Font face nastavuje typ písma ze seznamu.
  • Volba View → Character Encoding nastavuje kódování programu. Nechte na Unicode (UTF-8).
  • Volby v Edit:
    • Clear Search Entry smaže editační pole pro zadávání výrazů.
    • Clear History smaže historii zadávání výrazů
    • Copy kopíruje vybraný text.
    • Paste vloží obsah do editačního pole.
    • Preferences nastavení programu. Tady si zaškrtněte možnost Take words from the clipboard by default.
  • Ukončení programu - buď křížek nebo File → Exit, klávesová zkratka Ctrl+Q.

Ovládání

Do editačního pole vedle Word: napište požadované slovo. Toto slovo můžete napsat buď česky nebo anglicky, program si to sám určí a vypíše výsledek. Hledání výrazu se provádí stiskem tlačítka Look Up.

Odstranění

Jednoduše odstraňte balíky opendict a opendict-plugins-lingvosoft.

Problémy

Zatím jsem při používání programu na žádné problémy nenarazil.

Odkazy