XEphem

Xephem je výborný astronomický program vhodný i pro amatérské astronomy, stejně jako zájemce o pozorování oblohy. Kromě této volné verze, kterou si můžete zkompilovat, si také můžete zakoupit edici s rozšířenými funkcemi. Následující postup vyžaduje kompilování ze zdrojových kódů. Alternativně by se možná dalo instalovat z oficiálních balíků Debianu, avšak mohl by být problém se závislostmi.

Stažení zdrojového kódu

Zdrojový kód si můžete stáhnout na domovské stránce programu. Tato volná edice je podle licenční smlouvy pro osobní, vzdělávací, nekomerční použití nebo výzkumy financované z veřejných zdrojů.

Najděte Right-click and Save here to download now. Kliknutím na zvýrazněné here si stáhnete archív.

Instalace závislostí pro kompilaci

Tyto nástroje nejsou ve výchozím nastavení Ubuntu nainstalované. Instalaci můžete provést v terminálu zadáním

sudo apt-get install gcc lesstif2-dev libc6-dev libxmu-dev make

Potvrďte instalaci závislých balíků.

V závislosti na verzi Ubuntu bude potřeba nainstalovat správná verze knihovny gcc, např. gcc-4.1 pro Feisty Fawn. Kdyby tedy nefungovalo sudo apt-get install gcc, zadejte místo toho. gcc-4.1 nebo vaši verzi knihovny místo gcc.

Vytvoření adresáře a kompilace

  1. Vytvořte si adresář ve vaší domovské složce, např. Local.
  2. Přesuňte stáhnutý soubor do tohoto adresáře.
  3. Rozbalte soubor a dostanete ve složce Local adresářový strom xephem-3.7.2 (podle verze programu).
  4. Přesuňte se v terminálu do adresáře xephem-3.7.2/GUI/xephem:
    cd ~/Local/xephem-3.7.2/GUI/xephem
  5. Zadejte příkaz:
make MOTIF=../../libXm/linux86

Podle rychlosti počítače bude kompilování chvíli trvat.

Až odezní hlášky terminálu a objeví se znovu příkazová řádka, je program již přeložen a můžete ho zkusit spustit. Přesuňte se do adresáře ~/Local/xephem-3.7.2/GUI/xephem a zadejte ./xephem pro spuštění.

Po spuštění uvidíte nastavení programu:

Nastavte si pozorovací místo kliknutím na tlačítko Chicago, Illinois (předvolené). Z českých měst si můžete vybrat Prahu - tlačítkem Set nastavíte lokalitu.

Na spodu okna máte malé tlačítko Create, kterým si můžete přidat nové pozorovací místo, vyplněním:

  • Site name - vaše pozorovací místo, např. Č. Budějovice
  • Latitude - zeměpisná šířka
  • Longitute - zem. délka
  • Zone name - např. CET (Středoevropský čas)
  • DST name - nastavení letního času, i kdy začíná a končí(DST beg a DST end)

a dalších údajů.

Nejjednodušší bude možná předvolit si Prahu a případně to dodatečně pozdějí editovat.

Ovládání nejzákladnějších funkcí je jednoduché, proto jen stručně. Na předcházejícím obrázku vidíte hlavní okno programu. Nahoře máte příkazovou nabídku.

  • View → Data Table - efemeridy, východy a západy planet, jasnost aj.údaje.
  • View → Sun - obrázek Slunce, objeví se vám starý, nový se vám nahraje volbou Control → Download latest
  • … a mnoho dalších planet (Moon, Mars, Jupiter…)
  • View → Sky View - zobrazení noční oblohy

Program má mnoho dalších funkcí, další informace viz. článek na Root.cz a manuál programu.

Spouštění přes terminál funguje s tímto nastavením bez problémů. Pokud si chcete vytvořit spouštěč na plochu, musíte si vytvořit skript s tímto obsahem:

cd ~/Local/xephem-3.7.2/GUI/xephem
./xephem

Soubor si někam uložte a nastavte mu Spustitelný příznak. Poté už si můžete vytvořit spouštěč.

  • Poslední úprava: 2012/07/29 08:11
  • autor: Ubuntu