Inkscape

Inkscape je vektorový editor s příjemným poměrem výkon/uživatelská náročnost. Navíc je z velké většiny přeložen do češtiny, takže je pro tuzemské uživatele ještě přátelštější.

Instalace

Nainstalujte balík inkscape.

Vývojovou verzi můžete stáhnout na oficiální stránce (česky), pro instalaci využívá systému autopackage.

Spuštění

Inkscape můžete spustit z nabídky Aplikace → Grafika → Vektorový grafický editor Inkscape, případně příkazem inkscape.

Použití

Obecně platí, že levou lištou vytváříte nové prvky a měníte funkci kursoru a horní lišty slouží k editaci existujících prvků.

Pomocí Inkscape se dá vytvářet i poměrně složitá grafika, nicméně základem je vždy pár základních funkcí. Základní funkcí kurzoru je prvním kliknutím vybrání objektu a možnost měnit velikost, druhým klikem možnost otáčet (pomocí šipek v rozích) a klopit (pomocí šipek na stranách) a dvojklikem přechod k úpravě objektu.

Křivky

Na kreslení křivek jsou vhodné tři základní kreslící nástroje:

  • kreslení podle ruky - váš tah se převede na posloupnost bodů spojených čárou
  • kresba Bézierových křivek - určíte krajní body a směr, kam má křivka z těchto bodu mířit. Na Bézierovy křivky jsou převáděny všechny ostatní kreslící nástroje. Tažením ovládáte směr, kliknutím vytvoříte nový záchytný bod. Křivku ukončíte dvojklikem nebo jejím uzavřením (klikem na její začátek).
  • kaligrafická kresba - kresba podle ruky, která napodobuje kresbu kaligrafickým štětcem - vytváří tedy v jednom směru širokou stopu a v druhém tenkou

Poté, co si vytvoříte svou první čáru, můžete ji snadno upravit pomocí nástroje na úpravu křivek , při jeho aktivaci se v horní liště objeví nabídka na úpravu ostrosti vrcholu, přidání a odebírání vrcholů atd.

Volbou můžete „prohnout“ objekty vyskytující se v kruhu.

Pokud si nakreslíte předdefinovaný objekt (čtverec, kruh…) a poté Vám nejde pomocí bodového nástroje pohnout s nějakým bodem objektu, aplikujte na objekt funkci Křivka → Objekt na křivku (Shift+Ctrl+C).

Výplně

Výplně můžete vytvářet třemi způsoby:

  • pravým kliknutím na objekt a volbou Výplň a čáry - vpravo se objeví panel, na kterém můžete upravovat přesně inzerované věci. Pod přepínací oblastí výplň/vykreslení čáry/styl čáry je navíc volba Blur, tedy rozmazání (resp.rozostření) celého objektu, a Opacity, tedy průhlednost (přesněji neprůhlednost).
  • nástroj na tvorbu přechodů - vyberete si objekt, označíte ho a následně po zvolení nástroje pro tvorbu přechodů zvolíte v horní liště podrobnosti a pak protáhlým kliknutím vytvoříte barevný přechod ve vybraném objektu (přičemž to kliknutí vůbec nemusí být uvnitř objektu). Podle typu výplně tak vytvoříte dva nebo tři body - začátek s počáteční barvou a konec (u kruhového přechodu dva konce umožňující eliptický tvar) s koncovou barvou. Měnit barvy v přechodu můžete na spodní barevné liště prvým klikem, Set fill určuje koncovou barvu, Set stroke určuje výchozí barvu. Po zvolení můžete každou z barev upravit v nabídce Výplň a čáry na listu Výplň včetně jejich průhlednosti.
  • plechovka najde prostor, který je přibližně stejně barevný a na jeho území vytvoří nový objekt s vlastní výplní.

Zajímavé barevné funkce jsou v nabídce Efekty → Barva. Kupříkladu replace color umožní provést hromadnou změnu jedné barvy na druhou, funkce šedá škála převede barvy vybraných objektů do odstínů černé barvy - což jistě ocení lidé pohybující se v prostředí DTP.

Texty

Text se vkládá pomocí této ikony , dále můžete pomocí úpravy křivek upravovat jednotlivá písmena (můžete tak udělat třeba T roztažené nad celé slovo atd.), jinak je text objekt jako jakýkoli jiný - můžete na něj tedy aplikovat i barevný přechod.

Pokud vám pro tvarování textu nestačí otáčení a klopení, můžete ho umístit na křivku. Stačí vybrat současně text a nějakou křivku a zvolit Text → Umístit na křivku, pokud se nic nestane může to být tím, že jste text už roztáhli, klopili nebo otáčeli, případně tím, že objekt není považován za křivku - to ale můžete při jeho vybrání napravit Křivka → Objekt na křivku.

Připravené objekty

Inkscape umí vytvářet čtverce, kruhy, hvězdy a mnohoúhelníky, spirály a 3D krabice. Jejich ikony jsou natolik názorné, že snad není nutné je sem vkládat.

Seskupení objektů

Inkscape umí vytvářet z minimálně dvou či více samostatných objektů takzvané skupiny (Ctrl+G od slova Group). Seskupené objekty lze hromadně upravovat - měnit jejich velikost, otáčet, přebarvovat a jiné. Při vytváření složitějších kreseb je seskupování jednou z možností jak si udržet přehled o vzájemně souvisejících objektech. Seskupení lze kdykoli opět zrušit a pracovat s jednotlivými objekty (Shift+Ctrl+G).

Kombinace objektů

Kromě seskupení umí Inkscape objekty i kombinovat, což není totéž jako seskupit. Výsledkem funkce kombinace je „svaření“ označených objektů dohromady. Vlastnosti nového kombinovaného objektu se sloučí - bude mít jednotnou výplň i obrys. Zato se s pomocí kombinace dají provádět s objekty (pakliže se aspoň částečně překrývají) různé Booleovské funkce.

Zdrojové objekty

Kombinace vyloučením (XOR)

Vrstvy

Inkscape umí pracovat s vrstvami. Takzvanou vrstvu si lze představit jako průhledné sklo, na němž vytváříme kresby. Každý kdo začne v Inkscape kreslit, kreslí (aniž to ví či musí vědět) do první předdefinované vrstvy. K čemu to je? řeknete si možná. Vždyť objekty samotné lze řadit dopředu či dozadu dle potřeby. To je pravda, ale představme si tvorbu složitější kresby, kupříkladu mapy. Musí obsahovat vrstevnice, lesy, vodní toky, silnice, nápisy… Pokud budete tohle vše kreslit do jedné vrstvy, rychle se ztratíte v džungli objektů. Řešením je vytvořit si vrstvu pro topografii, hydrografii, demografii… a ty si dle potřeby zapínat či vypínat aby práce byla jasná a přehledná. A pokud Vás spolupracovník poprosí abyste mu poskytl obrysy urbanistiky, nemusíte pracně naklikávat jednu křivku domu po druhé, ale zapnete vrstvu s objekty zástavby, stisknete Ctrl+A (vybrat vše) a už můžete exportovat do souboru. Zajímavou a občas velmi užitečnou vlastností je možnost zvolit průhlednost a způsob vykreslování každé vrstvy. Je ale pravdou, že kupříkladu pro tvorbu běžného loga se o vrstvy nemusíte vůbec zajímat…

Protože ne všechno se dá vytvořit vektorovou grafikou a naopak ne všechno se v ní dá prezentovat, jistě oceníte i funkci importu bitmapy (nebo už vytvořeného SVG, případně objektu z Open Clipart Library) či exportu do formátu .png nebo .pdf. Export do .png probíhá přes jednoduché dialogové okno s nastavením vlastností po kliknutí na ikonu exportu

Do .pdf můžete soubor normálně uložit (respektive uložit jako), stačí při ukládání zvolit pdf jako formát.

Pokud chcete umístit na web nějakou svg grafiku, doporučuje se ji stejným postupem jako ukládání do pdf uložit jako Plain SVG, kvůli podpoře v prohlížečích.

Pokud přenášíte své soubory na jiný počítač, bývá vhodné před exportem převést všechny texty na křivky. Nikde nemáte zaručeno, že na druhém počítači budou ty samé fonty pro jaké máte odladěný svůj dokument.

Když přenesete vámi vytvořený svg soubor na jiný počítač, může se stát, že se místo importovaných bitmapových obrázků zobrazí pouze nápis „Linked image not found“. Je to způsobeno tím, že se uložila jen svg data a ne vložené obrázky. Ty se ovšem dají přiložit jednoduše pomocí Efekty → Obrázek → Přiložit všechny obrázky…

touto ikonou na horní liště, případně Soubor → Vlastnosti dokumentu nebo klávesovou zkratkou Ctrl+Shift+D vyvoláte okno změn vlastností dokumentu, tedy především šířku a výšku „papíru“, na dalších listech pak nastavení pro náročnější uživatele. Mimo jiné můžete zvolit tendenci k přichycování a podobně, bohužel tato část není přeložena do češtiny, takže jen krátce: Guides jsou vodítka - čáry, podél nichž se dá snadněji kreslit či srovnávat objekty. Grids jsou mřížky usnadňující kresby do pravoúhlého (rectangular) či lichoběžníkového (axonometric) systému. Snap jsou volby pro zachytávání objektů na jiné objekty, vodítka nebo mřížku. Nabídka Snap points obsahuje další dvě speciální možnosti které se využijí jen opravdu zřídka - přichytávání na průsečíky anebo na rotační centrum objektu.

Pro zajímavost: Inkscape umí dokonce nakreslit vodítka podle vybraného objektu: Objekt → Object to Guides .

Kromě běžného duplikování objektů umí Inkscape vytvářet i klony - rozdíl mezi duplikátem a klonem je ten, že klon je pevně spjat se svým originálem. To znamená, že když otočíte originálem, otočí se i všechny jeho klony a až na přesouvání se budou všechny úpravy na originálu aplikovat i na klony. Toto spojení zrušíte pomocí .

Klonování najdete i v menu Úpravy → Klonovat, kde je i možnost Dláždit pomocí klonů, tou se vytvoří plocha na které se opakují klony originálu.

Ne sice doslova, ale podle předlohy. Inkscape disponuje relativně mocným trasovacím nástrojem - myšleno tím schopností nakreslit vektorovou kopii bitmapového obrázku. Funkce se nachází v Křivka → Trasovat bitmapu. Nastavení parametrů se pochopitelně bude lišit podle druhu obrázku i podle toho jak má vypadat výsledek. Ale pár experimentů dá každému povědomí co který parametr ovlivňuje. Jak takové „překreslení“ může vypadat:

Originál

Trasovaná kresba

Originální obrázek vypůjčen z Awesome Wallpapers

Tvorba tzv. barcode je další funkcí Inkscape. Nabídku pro tvorbu čárových grafů najdete Efekty → Vykreslit → Barcode.

Užitečné je v případě tvorby čárových kódů vědět, že existuje jistá minimální velikost kterou musí graf mít aby byla zaručena jeho strojová čitelnost (cca 35×25 mm).

Inkscape umí importovat PDF: Soubor → Import - zobrazí se okno, kde si zvolíte další kritéria importu (načítá se vždy jen jedna strana). Program dodržuje kerning (mezery mezi písmeny) původního dokumentu, a při pokusu o úpravu textu se znaky přepisují přes sebe - je to vlastnost programu, který se tak snaží o zachování původního rozložení PDF. U některých souborů bude též nutno vložit další krok před editací textu: zrušit seskupení a zpřístupnit si tím samotný text.

Přímá úprava textu je možná po zrušení kerningu: hlavní menu → Text → Odstranit manuální kerning. Toto se musí opakovat u každého textového pole zvlášť, ale vyplatí se to.

Odstranění

Odstraňte balík inkscape.

Odkazy

  • Poslední úprava: 2019/02/25 18:21
  • (upraveno mimo DokuWiki)