libstdc_5

libstdc++5

Pro chod některých programů,jako např X-Lite či True Combat:Elite, jsou potřebné knihovny libstdc++.so.5, které se ale už nenachází v Ubuntu 8.04 Hardy Heron a novější. Proto si je musíte stáhnout a nainstalovat ručně.

Od verze 9.10 Karmic Koala se v repozitářích už nenachází vůbec, proto musíte použít repozitář z Ubuntu 9.04 Jaunty Jackalop.

Pro 32-bit systém

Stáhněte ze zdrojů vaší verze Ubuntu (zde Ubuntu 9.04 Jaunty Jackalop) soubor knihoven libstdc++5 a nainstalujte jej.

Pro 64-bit systém

Stáhněte ze zdrojů vaší verze Ubuntu (zde Ubuntu 9.04 Jaunty Jackalop) soubor knihoven ia32-libs

Z tohoto staženého souboru ia32-libs_2.7ubuntu6.1_amd64.deb rozbalte ven požadované soubory libstdc++.so.5 a libstdc++.so.5.0.7, uložené v cestě data.tar.lzma/./usr/lib32

Vybalené soubory nakopírujte(jako správce) do adresáře /usr/lib32/ ve vašem PC. Hotovo

Možná můžete stažený soubor ia32-libs_2.7ubuntu6.1_amd64.deb normálně nainstalovat, ale nevím, zda-li nemohou nastat nějaké komplikace. Přeci jen, tam je i hodně jiných knihoven. Pokud to vyzkoušíte, prosím napište to sem.

1.zkušenost: Stažený soubor ia32-libs_2.7ubuntu6.1_amd64.deb nejde normálně nainstalovat, systém hlásí, že novější verze balíčku již existuje.

Odkazy

  • Poslední úprava: 2019/02/25 18:21
  • (upraveno mimo DokuWiki)