programy:multimédia:pitivi

Rozdíly

Zde můžete vidět rozdíly mezi vybranou verzí a aktuální verzí dané stránky.

Odkaz na výstup diff

Obě strany předchozí revize Předchozí verze
Následující verze
Předchozí verze
programy:multimédia:pitivi [2014/07/29 22:03]
ToMášMarný Instalace, Spuštění, Odstranění - správné namespaces
programy:multimédia:pitivi [2019/02/25 18:21] (aktuální)
Řádek 1: Řádek 1:
 +====== Pitivi ======
  
 +{{pitivi_logo.png?​40}} Pitivi je Free a Open Source nelineární videoeditor postavený na základech poskytovaných multimediální knihovnou GStreamer.
 +Cílem tohoto projektu je vytvořit výkonné a flexibilní řešení - videoeditor - jak pro nováčky, tak pro zkušenější uživatele. Cílem je také vytvořit uživatelsky přívětivou a zároveň výkonnou aplikaci, jež nebude omezovat vaši kreativitu. Tento manuál by měl pomoci porozumět základnímu konceptu aplikace a umožnit vám rychle nastartovat vaši vlastní tvorbu.
 +
 +{{ .:​Pitivi_screenshot-1404.png?​450 }}
 +
 +====== Instalace ======
 +
 +{{:​apt.png}} [[:​Instalace programů|Nainstalujte]] balík [[apt://​pitivi|pitivi]].
 +
 +====== Spuštění ======
 +
 +{{:​navigate.png}} Aplikaci můžete spustit z nabídky **Aplikace → Zvuk a video → Pitivi**, případně [[:​Terminál|příkazem]] ''​pitivi''​.
 +
 +====== Odstranění ======
 +
 +{{:​clear.png}} [[:​Instalace programů|Odeberte]] balík ''​pitivi''​.
 +
 +====== GStreamer a kompatabilita ======
 +
 +Výkonnost Pitivi je postavena na základech multimediální knihovny GStreamer. GStreamer je požíván tucty multimediálních aplikací v nejrůznějších desktopových prostředích,​ operačních systémech a architekturách.
 +
 +Z toho pro uživatele v zásadě vyplývají tři věci:
 +
 +  * Teoreticky můžete importovat pěkné množství multimediálních souborů, které jsou podporovány knihovnou GStreamer (ale aktuální stav implementace tomu neodpovídá,​ viz. následující text).
 +
 +  * Při renderování obsahu vašich projektů a tedy vytváření multimediálních souborů můžete opět použít kterýkoliv podporovaný kontejner či kombinaci kodeků z knihovny GStreamer.
 +
 +  * Chcete-li maximalizovat schopnosti Pitivi a minimalizovat případné chyby, pak si musíte zajistit poslední verzi knihovny GStreamer. A to z toho důvodu, že vývojáři pracují na projektu Pitivi a zároveň usilovně spolupracují na odstraňování problémů přímo v knihovně GStreamer (místo toho, aby problémy řešili dočasným způsobem v rámci projektu Pitivi).
 +
 +===== Několik slov o "​nekompatibilních"​ kodecích =====
 +
 +Použití některých kodeků, jež využívá knihovna GStreamer, jako je například Fluendo MP3 a MPEG, může uživatele mást, přestože totiž poskytují legální způsob, jak přehrávat soubory (v zemích, které respektují softwarové patenty), nemusí tyto kodeky dokonale odpovídat specifikaci,​ která je uvedena v knihovně GStreamer.
 +
 +Někteří uživatelé hlásili problémy při použití těchto kodeků (rozumějte:​ nebyli schopni importovat MP3 soubory, když měli tyto kodeky nainstalovány).
 +
 +Důvodem těchto problémů je, že se jedná o kodeky, které jsou zaměřeny na přehrávání multimediálního obsahu, a nejsou zcela kompatibilní se specifikací podle knihovny GStreamer, proto Pitivi nemůže takové soubory korektně editovat.
 +
 +Tato situace je nešťastná. Pokud se případně podaří upravit tyto kodeky tak, aby byly plně použitelné knihovnou Gstreamer pro přehrávání i pro editaci, pak tyto kodeky budou taky pracovat s Pitivi.
 +
 +V zemích, které nepodporují ochranu softwarových patentů, můžete jednoduše použít sadu pluginů pro Gstreamer, jež možnosti knihovny z tohoto hlediska rozšíří.
 +
 +===== Slovo o kodecích podporujících editaci =====
 +
 +Některé formáty, jako je MPEG, jsou zaměřeny pouze na přehrávání,​ a neprovádějí kompresi každého snímku nezávisle. I když cílem Pitivi je podporovat práci s těmito soubory, určité operace (jako je rychlé vyhledávání) nebudou prováděny tak dobře, jako při použití videa, jehož komprese je nezávislá na snímku (jako je například MJPEG nebo DV).
 +
 +====== Systémové požadavky ======
 +
 +Posuzujeme-li požadavky z hlediska hardware, pak je typické, že pro editaci videa je vyžadován poměrně výkonný počítač, v závislosti na tom, jaký druh videa editujete. V uplynulých letech došlo k velmi výraznému nárůstu výkonu počítačů,​ spolu s ním však také vzrostly nároky na kvalitu videa.
 +
 +Editování HD (High Definition) videa obvykle vyžaduje (alespoň v době psaní tohoto textu) použití nejnovějších modelů hardwaru (v závislosti na použitém kodeku), zatímco editace SD (Standard Definition) videa může být prováděna na počítači s poměrně skromnou konfigurací. Je na vás zajistit si adekvátní vybavení. Obecně by váš počítač měl být schopen minimálně plynule přehrávat vaše multimediální soubory pomocí aplikace Totem.
 +
 +Je ale také možné použít nižší kvalitu vaší stopáže během editace a vysokou kvalitu během renderování finálního výstupního souboru, toto vám do určité míry umožní překonat hardwarové omezení. Tomuto se říká “proxy editace”. Tato možnost nicméně není dosud v Pitivi implementována.
 +
 +====== Přehled uživatelského rozhraní ======
 +
 +===== Hlavní okno aplikace =====
 +
 +Hlavní okno aplikace, jak lze vytušit, je okno obsahující hlavní komponety uživatelského rozhraní Pitivi, jmenovitě: menu, nástrojovou lištu, časovou osu a různé uživatelsky přizpůsobitelné komponenty (seznam zdrojů, náhled, seznam efektů, seznam přechodů).
 +
 +===== Menu =====
 +
 +Menu aplikace obsahuje všechny možné akce dostupné z nástrojové lišty a mnoho dalších navíc. Menu také obsahuje některá trvale působící nastavení, stejně tak umožňuje vyvolat dialogy pro “Nastavení projektu” a “Nastavení” aplikace Pitivi.
 +
 +Menu aplikace nemůže být skryto.
 +
 +===== Nástrojová lišta =====
 +
 +Nástrojová lišta poskytuje přístup k nejběžněji používaným funkcím Pitivi. Všechny položky nástrojové lišty mohou být zpřístupněny z menu aplikace. Zobrazení nástrojové lišty může být aktivováno nebo deaktivováno volbou v menu **Zobrazení**.
 +
 +Podržíte-li kurzor nad ikonou příslušné funkce v nástrojové liště, zobrazí se nápověda k této funkci.
 +
 +{{ .:​PiTiVi_napoveda.png?​300 }}
 +
 +===== Pravítko =====
 +
 +Role pravítka má zásadní význam při práci s časovou osou. Kromě měření času (v sekundách) je to primární nástroj k nastavení aktuální pozice přehrávání (a tedy taky pozice v čase).
 +
 +Aktuální pozice přehrávače je indikována červenou vertikální linkou.
 +
 +Technická poznámka: Zvětšíme-li pravítko, pak jsou jednotlivé snímky budoucího videa vizuálně reprezentovány na pravítku jako střídající se světlá a tmavá políčka ve spodní části pravítka; velikost těchto políček odpovídá nastavení snímkové frekvence v dialogu “Nastavení projektu”.
 +
 +Chcete-li změnit vaši pozici v čase, klikněte kdekoliv na pravítku. Také můžete posunout časový ukazatel tím, že na něj kliknete a za současného držení tlačítka myši jej přesunete.
 +
 +===== Časová osa =====
 +
 +Časová osa představuje základní komponentu uživatelského rozhraní, jež bude používána pro editaci. Je to vizuální, časově proporcionální reprezentace vašeho projektu.
 +
 +===== Přehrávací lišta =====
 +
 +Na této liště, která je umístěna pod náhledem, jsou umístěna tlačítka, pomocí nichž ovládáme:
 +
 +  * Přehrávání časové osy.
 +
 +  * Přehrávání klipu umístěného v seznamu zdrojů.
 +
 +Tlačítko **Play** se transformuje na **Pause** v okamžiku přehrávání a naopak zpět na tlačítko **Play** v okamžiku, kdy je přehrávání pozastaveno.
 +
 +===== Náhled =====
 +
 +Náhled zobrazuje:
 +
 +  * Vámi tvořené video při přehrávání.
 +  * Videosnímek odpovídající aktuální časové pozici.
 +  * Okamžitý náhled při ořezávání počátku nebo konce klipu.
 +
 +===== Seznam zdrojů =====
 +
 +Seznam zdrojů zobrazuje importované multimediální soubory do vašeho projektu.
 +
 +====== Začínáme ======
 +
 +===== Vytváříme projekt =====
 +
 +Při prvním spuštění Pitivi je vytvořen nový prázdný projekt. Chcete-li otevřít existující projekt, použijte **Soubor** → **Otevřít** nebo zmáčkněte <​key>​C-o</​key>​.
 +Máte-li již otevřený a tedy aktivní nějaký projekt a přejete-li si otevřít nový projekt, použijte **Soubor** → **Nový** nebo zmáčkněte <​key>​C-n</​key>​.
 +
 +===== Editace nastavení projektu =====
 +
 +{{ .:​PiTiVi_Nastaveni_projektu.png?​450 }}
 +
 +Když si vytvoříte nový projekt, měli byste si zkontrolovat nastavení různých parametrů tohoto projektu, jako je například snímková frekvence, rozlišení obrazu či preferované kodeky. Rozlišení obrazu pak například ovlivní, v jakém poměru poměr stran bude videosnímek zobrazen při náhledu.
 +K editaci nastavení projektu použijte menu **Projekt** → **Nastavení projektu**.
 +
 +===== Ukládání projektu =====
 +
 +Chcete-li uložit svou práci – svůj projekt, použijte menu **Soubor** → **Uložit**,​ tlačítko **Uložit** v hlavní nástrojové listě aplikace nebo zmáčkněte <​key>​C-s</​key>​.
 +
 +Poznámka: Uložením projektu nevytváříme žádný multimediální datový soubor. Jak se vytváří takový multimediální datový soubor, je popsáno v odstavci Vykreslování (Rendering).
 +
 +Při prvním pokusu o uložení projektu se objeví dialogové okno, pomocí kterého jste dotázáni, kde má být projekt uložen a jak jej chcete pojmenovat.
 +
 +Chcete-li uložit projekt do jiného souboru, použijte **Soubor** → **Uložit jako** nebo zmáčkněte <​key>​C-S-s</​key>​. Tento postup můžete použít, budete-li chtít vytvořit nějakou odlišnou verzi vašeho projektu.
 +
 +===== Import multimediálních souborů =====
 +
 +Do budoucna je plánována realizace importu multimediálních souborů z různých zdrojů. Nicméně v tomto okamžiku je jedinou možností načíst soubor přímo z pevného disku v počítači.
 +
 +==== Importování souborů ====
 +
 +=== Použití dialogu pro výběr souborů ===
 +
 +Pomocí dialogu pro výběr souborů můžete importovat multimediální soubory do seznamu zdrojů.
 +
 +Chcete-li importovat soubor, použijte menu **Projekt** → **Importovat klipy ...**, tlačítko **Importovat klipy ...** na nástrojové liště nebo zmáčkněte <​key>​C-i</​key>​.
 +
 +Objeví se následující dialogové okno:
 +
 +Chcete-li zvolit více souborů najednou, zmáčkněte <​key>​C</​key>​ nebo <​key>​S</​key>​. Také můžete importovat všechny soubory z vybraného adresáře (a ze všech jeho podadresářů),​ použijete-li volbu menu **Projekt** → **Importovat složku klipů...**.
 +
 +=== Použití metody "​táhni a pusť" (drag and drop) ===
 +
 +Koncept "​táhni a pusť" je dobře známou metodou, jak přenést data mezi aplikacemi.
 +
 +Tato vlastnost může:
 +
 +  * být použita k rychlému a snadnému importu hudby nebo videoklipů z přehrávače (jako je Rhythmbox nebo Totem) jejich přetažením nad seznam zdrojů v Pitivi.
 +
 +  * dovolit použití plnohodnotného správce souborů (jako je Nautilus, Thunar, Dolphin nebo Konqueror) místo dialogu určeného k výběru souborů.
 +
 +  * rozšířit vyhledávací možnosti programu o schopnosti jiných aplikací (jako je Rhythmbox, Tracker, GNOME Search Tool atd.).
 +
 +===== Použití seznamu zdrojů =====
 +
 +==== Náhled klipu umístěného v seznamu zdrojů ====
 +
 +Chcete-li si prohlédnout klip před tím, než jej umístíte na časovou osu projektu, stačí když na něj dvakrát kliknete (zatím nefunguje) nebo na něj kliknete pravým tlačítkem a z lokálního menu zvolíte **Přehrát klip**.
 +
 +{{ .:​PiTiVi_prehrat_klip.png?​450 }}
 +
 +==== Rychlé vyhledávání ====
 +
 +Chcete-li rychle vyhledat klip v seznamu zdrojů a znáte počáteční písmena jeho názvu, pak stačí, když kliknete kdekoliv v prostoru seznamu zdrojů a začnete psát jméno hledaného souboru.
 +
 +  * Tak, jak budete psát, bude vybrán první soubor, který bude odpovídat zapsaným znakům.
 +
 +  * Můžete pokračovat psaním dalších znaků a tím upřesnit výběr souboru.
 +
 +  * Pokud zadaným znakům vyhovuje více souborů, můžete použít šipku nahoru a dolů k volbě jiného souboru.
 +
 +Tato metoda umožňuje pouze vyhledávání od začátku názvu souboru.
 +
 +==== Zobrazovací módy ====
 +
 +Seznam zdrojů může zobrazit vaše klipy ve formě prostého seznamu (**Zobrazení** → **Show Clips as a List**)
 +
 +nebo jako ikony představující jednotlivé klipy (**Zobrazení** → **Show Clips as Icons**).
 +
 +Seznam poskytuje více podrobností o klipu, ikon pro změnu může být zobrazeno více najednou, aniž byste museli hledat zdrojový klip na některé jiné stránce (zejména na monitorech s velkým rozlišením).
 +
 +===== Provádění výběru =====
 +
 +==== Výběr jediné položky ====
 +
 +Chcete-li vybrat soubor nebo klip v Pitivi, klikněte na něj.
 +
 +==== Výběr více položek najednou ====
 +
 +Výběr více položek najednou vám umožní provádět některé akce najednou s více klipy (přesun, smazání, seskupení atd.)
 +
 +Výběr několika sousedních položek:
 +
 +  - Klikněte na první položku.
 +  - Držte klávesu <​key>​S</​key>​.
 +  - Klikněte na poslední položku.
 +
 +Výběr několika položek, které spolu nesousedí:
 +
 +  - Podržte klávesu <​key>​C</​key>​.
 +  - Klikněte na všechny položky, které chcete vybrat.
 +
 +Chcete-li zrušit výběr některé z položek, pak na ni klikněte za současného držení klávesy <​key>​C</​key>​. Tato technika může být použita společně s postupem, který je popsán při “výběru několika sousedních položek”,​ viz. výše.
 +
 +===== Vkládání média na časovou osu projektu =====
 +
 +Ze seznamu zdrojů můžete vložit jeden nebo více klipů jejich vybráním (za použití klávesy <​key>​C</​key>​ nebo <​key>​S</​key>​) a
 +
 +  * tím, že je chytíte a upustíte na zvolené místo časové osy.
 +
 +  * stlačením klávesy <​key>​Insert</​key>​ nebo použitím volby menu **Projekt** → **Vložit na konec časové osy**. Tyto klipy pak budou vloženy na konec časové osy.
 +
 +===== Použití klipů =====
 +
 +==== Klipy versus soubory ====
 +
 +  * Soubory jsou data na vašem harddisku (videa, hudba, obrázky atd.), jež mohou být zpřístupněna v Pitivi načtením do seznamu zdrojů a tím zahrnuta do vašeho projektu.
 +
 +  * Klipy jsou vizuální reprezentací vašich souborů na časové ose. Klipy reprezentují určitou časovou periodu na časové ose a mohou být editovány zcela nezávisle na souborech: pokaždé, když přetáhnete soubor ze seznamu zdrojů na časovou osu vytvoříte nový klip. Tentýž soubor může být znovu použit k vytvoření libovolného množství různých klipů.
 +
 +Protože je Pitivi nedestruktivní editor, editujete pouze klipy, nikoliv soubory. Soubory tedy zůstávají beze změny.
 +
 +==== Posun klipů podél časové osy ====
 +
 +Klip můžete posouvat v rámci jediné vrstvy nebo jej můžete přesunout do jiné vrstvy.
 +
 +Označte klip tím, že na něj kliknete, a pak jej potáhněte na jiné místo a uvolněte tlačítko myši. Přetažením v horizontálním směru ponecháte klip ve stejné vrstvě, budete-li jej však přemisťovat vertikálně,​ přesunete klip do jiné vrstvy.
 +
 +Chcete-li přesunout více klipů najednou, použijte klávesy <​key>​C</​key>​ nebo <​key>​S</​key>​ k výběru více klipů. Vybrané klipy nemusejí být ve stejné vrstvě. Pak přesuňte klipy stejně, jak byste to udělali s jediným klipem. Vzájemná relativní pozice všech vybraných a přesouvaných klipů zůstane nezměněna.
 +
 +=== Posun klipu společně s posunem následujících klipů ===
 +
 +Při popotahování klipů podél časové osy můžete využít techniky, jež je popsána v odstavci Ořezávání klipu s posunem následujících klipů, k přesunu všech v čase následujících klipů (tedy klipů, které začínají za klipem, jehož polohu právě editujete). Tohoto pak můžete využít při vkládání klipu mezi jiné klipy, případně k zaplnění vzniklé mezery po odstranění některého klipu.
 +
 +  - Klikněte a táhněte klip, jenž chcete přesouvat, držte při tom tlačítko myši zmáčknuté.
 +  - Během přetahování klipu na jiné místo držte stisknutou klávesu <​key>​S</​key>​.
 +  - Chcete-li ukončit přesun klipu, uvolněte tlačítko myši a následně uvolněte klávesu <​key>​S</​key>​.
 +
 +Dojdete-li během přesunu klipu k názoru, že již nechcete přesouvat všechny následující klipy zároveň, pak stačí když uvolníte klávesu <​key>​S</​key>​ ještě před tím, než uvolníte tlačítko myši.
 +
 +===== Pohyb po časové ose =====
 +
 +==== Rolování ====
 +
 +K rolování časové osy můžete použít posuvníky (které se nacházejí v pravé a dolní části panelu s časovou osou), použijte kolečka myši, chcete-li se na časové ose posouvat horizontálně,​ případně stlačte zároveň klávesu <​key>​S</​key>,​ chcete-li se posouvat vertikálně po jednotlivých vrstvách.
 +
 +==== Lupa ====
 +
 +Aktuální zvětšení časové osy ovlivňuje přesnost vaší editace a zároveň vaši schopnost rychle se přesouvat podél časové osy:
 +
 +  * Když časovou osu zvětšíte,​ videoklipy budou zobrazovat více detailů a na audioklipech rozpoznáte detailnějším způsobem časový průběh signálu, toto vám umožní precizní editaci.
 +
 +  * Když zmenšíte časovou osu, budete se moci rychleji pohybovat podél časové osy. Zvětšení či zmenšení časové osy tedy může být použito společně s rolováním k tomu, abyste se rychle přemístili z jednoho místa časové osy na jiné místo.
 +
 +Měnit měřítko, ve kterém je časová osa zobrazena, můžete zmáčknutím klávesy <​key>​C</​key>​ za současného použití kolečka myši, případně použijete-li položky menu **Zobrazení** → **Zvětšit** a **Zobrazení** → **Zmenšit** nebo potáhnete-li posuvník lupy, jenž je umístěn nalevo od pravítka časové osy.
 +
 +=== "​Překlikávání"​ mezi úrovněmi zvětšení ===
 +
 +Budete-li chtít rychle jediným kliknutím nastavit jiné zvětšení časové osy, klikněte kolečkem myši na jiné místo posuvníku lupy.
 +
 +==== Přesun čtecí hlavy ====
 +
 +Kliknutím kdekoliv na pravítku či na panelu časové osy dojde k přesunu čtecí hlavy (za předpokladu,​ že máte již vytvořen nějaký klip na časové ose).
 +
 +Kliknete-li na časovou osu:
 +
 +  * pak je-li klip pod kurzorem myši, vyberete zároveň tento klip (chcete-li podrobnější informace pak vizte popis v odstavci Výběr několika položek).
 +
 +  * není-li žádný klip pod kurzorem, pak bude výběr všech vybraných klipů (jsou-li nějaké) zrušen.
 +
 +Když kliknete na pravítko, změní se pouze aktuální pozice hlavy, ale nezmění se případný výběr klipů.
 +
 +==== Popotahování čtecí hlavy ====
 +
 +Popotahování čtecí hlavy vám umožňuje:
 +
 +  * Zhruba vyhledat pozici na časové ose, například při hledání chyb ve vašem projektu.
 +
 +  * Opakovaně prohlížet vytvářenou scénu tam i pozpátku.
 +
 +Chcete-li potahovat čtecí hlavu, klikněte na pravítko a přesouvejte ukazatel myši se stále stlačeným tlačítkem myši.
 +
 +Přetahovat čtecí hlavu také můžete tak, že budete potahovat černou vertikální linku, jež naznačuje pozici čtecí hlavy podél časové osy.
 +
 +===== Porozumění vrstvám =====
 +
 +Na konceptu použití časové osy rozdělené do vrstev jsou založeny veškeré pokročilé techniky editace videa: kompozice jednotlivých klipů, mixování klipů, přidávání titulků – to vše je umožněno díky vrstvám.
 +
 +Představa vrstev je jednodušší,​ když si je představíme jako obrázky namalované na skle. Položíme-li několik takových skel s obrázky na sebe, pak každé takové sklo představuje jednu vrstvu. Bude-li horní sklo zcela pomalováno obrázkem, pak žádná část z obrázků ležících na spodních sklech nebude vidět.
 +
 +Jestliže ale bude pomalována pouze část onoho horního skla, pak budete moci vidět, co je na sklech, která leží níže.
 +
 +==== Sytost (to, jak kvalitní "​nátěr"​ jste vytvořili) ====
 +
 +Každá vrstva (a každý klip) má svou vlastní průhlednost. Budeme-li pokračovat s přirovnáním ke sklu, bude-li vrstva barvy dostatečně tenká, pak přes ni budeme trochu vidět. Vizuálně, sytost 100% znamená, že nemůžete vidět klipy ve vrstvách ležících pod vrstvou, ve které je klip, a sytost 50% znamená, že klip na nižší vrstvě můžete částečně vidět.
 +
 +==== Jak se toto přirovnání transformuje z hlediska uživatelského rozhraní ====
 +
 +Zatímco v reálném životě naskládáte jednotlivá skla na sebe v trojrozměrném prostoru, váš monitor má pouze dvě dimenze. Proto vrchní vrstva, “ta, jež je zcela nahoře” (“Z” osa z hlediska reálného světa), je umístěna “nahoře”,​ na “Y” ose.
 +
 +Následující diagram ilustruje jednotlivé “kusy skla” (nalevo) a to, jak se jeví jako “vrstvy” v uživatelském rozhraní Pitivi (napravo).
 +
 +{{ .:​PiTiVi_vrstvy.png?​450 }}
 +
 +Klipy umístěné na vyšší vrstvě překryjí klipy na nižší vrstvě, pokud ovšem nemají sytost nižší než 100% (tak, jak je zobrazeno na obrázku výše).
 +
 +==== Přidávání a odstraňování vrstev ====
 +
 +Vrstvy jsou vytvářeny a odstraňovány automaticky. V Pitivi neexistuje žádný "​správce vrstev"​ (alespoň doposud není).
 +
 +Chcete-li vytvořit vrstvu, jednoduše táhněte klip dolů, dokud se neobjeví nová vrstva.
 +
 +Není-li žádný klip v existující vrstvě, dojde k automatickému odstranění vrstvy. Tedy, chcete-li odstranit vrstvu, jednoduše přetáhněte všechny klipy, které jsou v dané vrstvě, do jiných vrstev.
 +
 +==== A co audiovrstvy?​ ====
 +
 +Na rozdíl od vrstev videoklipů,​ několik zvuků se (objektivně) navzájem ​ neblokuje. Proto, máte-li několik audio  klipů v několika vrstvách bude jejich zvuk mixován dohromady. Ovládáním hlasitosti těchto audioklipů jednoduše změníte jejich relativní hlasitost.
 +
 +====== Editování klipů na časové ose ======
 +
 +===== Ořezávání =====
 +
 +Ořezávání je činnost, při které je měněn počáteční nebo koncový bod klipu na časové ose.
 +
 +==== Ořezání jednotlivého klipu ====
 +
 +Když přiblížíte kurzor myši začátku nebo konci klipu, změní kurzor svou podobu. V tomto okamžiku můžete kliknout a potáhnout jeden z konců klipu, ať už doprava počátek klipu nebo doleva konec klipu, a tímto klip zkrátit.
 +
 +Klipy, které jsou seskupeny dohromady, jako například videoklip s asociovaným audioklipem,​ budou při této operaci zkráceny zároveň. Budete-li chtít ořezat pouze audiočást klipu nebo pouze videočást klipu, musíte nejprve takto seskupený klip rozdělit.
 +
 +==== Ořezávání klipu s posunem následujících klipů ====
 +
 +Tento způsob editování je variantou k základnímu ořezávání,​ která navíc oproti základnímu způsobu ořezávání klipu přesouvá všechny “následující” klipy (tedy klipy, jež začínají za právě editovaným klipem), díky čemuž nevniká mezi klipy mezera.
 +
 +  * Poznámka: Posun je aplikován na všechny “následující” klipy bez ohledu na to, zda jsou ve stejně vrstvě nebo ne...
 +
 +Před editací:
 +
 +{{ .:​PiTiVi_pred_1.png?​450 }}
 +
 +Po editaci:
 +
 +{{ .:​PiTiVi_po_1.png?​450 }}
 +
 +Chcete-li provést ořezání klipu s posunem následujících klipů:
 +
 +  - Umístěte kurzor na konec jednoho ze dvou sousedících klipů a, po té co se objeví ořezávací kurzor, zmáčkněte tlačítko myši.
 +  - Stlačte a držte klávesu <​key>​S</​key>​.
 +  - Potáhněte požadovaným způsobem ukazatel.
 +
 +Tento způsob editace může být použit také tehdy, chceme-li pouze přesouvat klipy podél časové osy. Podrobné vysvětlení naleznete v odstavci Posun klipu společně s posunem následujících klipů.
 +
 +==== Současné ořezávání sousedících klipů ====
 +
 +Tento způsob editace klipů je variantou základního způsobu ořezávání,​ jež však navíc ořezává sousedící klipy tak, aby nevnikla na časové ose mezera.
 +
 +  * Poznámka: Ořezání je aplikováno na všechny v dané chvíli sousedící klipy bez ohledu na to, ve které vrstvě jsou.
 +
 +Před editací:
 +
 +{{ .:​PiTiVi_pred_2.png?​450 }}
 +
 +Po editaci:
 +
 +{{ .:​PiTiVi_po_2.png?​450 }}
 +
 +Chcete-li provést ořezání sousedících klipů:
 +
 +  - Umístěte kurzor na konec některého ze sousedících klipů tak, aby se zobrazil ořezávací kurzor, zmáčkněte tlačítko myši.
 +  - Zmáčkněte a držte klávesu <​key>​C</​key>​.
 +  - Potáhněte ukazatel do požadované pozice.
 +
 +===== Rozdělení klipu =====
 +
 +Rozdělením klipu získáme dva sousedící klipy.
 +
 +V Pitivi je rozdělení klipu netypickou operací v tom smyslu, že nemusíte před provedením této operace “aktivovat” nějaký konkrétní nástroj. Rozdělení klipů bude provedeno v místě, kde se aktuálně nachází čtecí hlava na časové ose (viz. také Přesun čtecí hlavy). Kombinováním s Lupou, procházením snímků pomocí klávesnice nebo s Popotahováním čtecí hlavy je dělení snímků nejen rychlé a efektivní, ale také velmi přesné.
 +
 +Výběr klipu ovlivní rozdělení následujícím způsobem:
 +
 +  * Budou rozděleny pouze vybrané klipy pod čtecí hlavou.
 +
 +  * Není-li žádný klip vybrán, budou rozděleny všechny klipy pod čtecí hlavou.
 +
 +Chcete-li rozdělit jediný klip:
 +
 +  - Klikněte na klip.
 +  - Nastavte pozici čtecí hlavy (je-li to třeba).
 +  - Klikněte na tlačítko “Rozdělit klip v místě kurzoru”, které je umístěno na nástrojové liště časové osy nebo stlačte klávesu <​key>​s</​key>​.
 +
 +Chcete-li rozdělit všechny klipy ve všech vrstvách:
 +
 +  - Klikněte na prázdnou plochu na časové ose (tímto způsobem zrušíte jakýkoliv výběr u klipů).
 +  - Nastavte pozici čtecí hlavy (je-li změna pozice potřebná).
 +  - Klikněte na tlačítko “Rozdělit klip v místě kurzoru”, které je umístěno na nástrojové liště časové osy nebo stlačte klávesu <​key>​s</​key>​.
 +
 +Chcete-li rozdělit více vybraných klipů:
 +
 +  - Nastavte pozici čtecí hlavy na místo, kde si přejete klipy rozdělit.
 +  - Přidejte klipy do výběru nebo odstraňte klipy z výběru kliknutím myši za současného stlačení klávesy <​key>​C</​key>​. Tyto akce neovlivní pozici čtecí hlavy.
 +  - Klikněte na tlačítko “Rozdělit klip v místě kurzoru”, které je umístěno na nástrojové liště časové osy nebo stlačte klávesu <​key>​s</​key>​.
 +
 +===== Interpolační křivky klipů =====
 +
 +{{. :​PiTiVi_krivky.png?​450 }}
 +
 +Určité typy klipů (aktuálně jsou to pouze audioklipy) podporují interpolaci určitých vlastností v čase trvání klipu. Uživatel může přidat jeden nebo více kontrolních bodů na interpolační křivku vlastnosti. Pitivi pak prokládá interpolační křivku těmito kontrolními body. V současnosti je však podporována pouze lineární interpolace (úsečky mezi body).
 +
 +==== Obecné použití ====
 +
 +Křivky jsou předdefinované vlastnosti klipů, a nemohou být proto uživatelem odstraněny. Počáteční a koncový kontrolní bod interpolační křivky leží na počátečním a koncovém bodě klipu a také nemůže být odstraněn uživatelem.
 +
 +  * Můžete však přidat nový kontrolní bod pomocí dvojkliku na interpolační křivku v místě, kde ještě není žádný kontrolní bod.
 +
 +  * Můžete odstranit kontrolní bod dvojklikem na něj.
 +
 +  * Můžete přesunout kontrolní bod v čase pomocí myši. Kontrolní bod můžete umístit do kteréhokoliv místa klipu, dokonce takto můžete změnit pořadí kontrolních bodů.
 +
 +  * Můžete kliknout a vertikálně táhnout, a tím nastavit pozici pro kterýkoliv segment interpolační křivky mezi dvěma kontrolními body.
 +
 +==== Audiokřivky ====
 +
 +U křivky hlasitosti představuje vertikální pozice křivky hlasitost klipu v rozsahu od 0 do 200 %.
 +
 +==== Video kompozitní křivky ====
 +
 +Vertikální pozice křivky představuje alfa kanál klipu (sytost), hodnota je nastavitelná v rozsahu od 0 do 100 %. Více podrobností viz. odstavec “Porozumění vrstvám”.
 +
 +====== Přechody ======
 +
 +===== Zeslabování a zesilování obrazu =====
 +
 +V Pitivi existuje možnost provést postupné zeslabení (případně zesílení) obrazu vybraného klipu vhodným nastavením průběhu interpolační křivky, jež kontroluje sytost obrazu. Jak již bylo uvedeno, tvar interpolační křivky je dán polohou kontrolních bodů interpolační křivky.
 +
 +Například,​ chceme-li ztmavit obraz videoklipu až na černou barvu:
 +
 +  * Dvojklikem na interpolační křivce ovládající sytost obrazu nejprve vytvoříme počáteční kontrolní bod stmívání.
 +
 +{{ .:​PiTiVi_prechdy_1.png?​450 }}
 +
 +  * Pak klikneme na poslední kontrolní bod a přetáhneme jej dolů.
 +
 +{{ .:​PiTiVi_prechody_2.png?​450 }}
 +
 +====== Vykreslování ======
 +
 +Vykreslování je proces, při kterém je váš projekt exportován do nové, finální podoby – do multimediálního souboru. Vykreslování pouze vytváří nový “vykreslený” videosoubor,​ ale neovlivní žádným způsobem samotný projekt; stále totiž můžete projekt editovat a znovu a znovu jej pak vykreslovat tolikrát, kolikrát budete potřebovat.
 +
 +  - Z menu **Projekt** použijte volbu **Vykreslit projekt**.
 +  - V zobrazeném dialogu pak můžete nastavit způsob kódování a další detaily, potřebujete-li použít odlišné nastavení než to, které je nastaveno v projektu.
 +  - Klikněte na tlačítko **Vykreslit**.
 +
 +====== Problémy a chyby ======
 +
 +===== Chyby při importu =====
 +
 +V současné době jsou známy čtyři typy chyb, které se vyskytují v okamžiku, kdy se snažíte importovat soubor do seznamu zdrojů:
 +
 +  * **Překročení časového limitu**: Jestliže import souboru trvá déle než 10 sekund, pak bude takový pokus o import souboru ignorován.
 +
 +  * **Poškozený kodek**: Může se jednat o chybu kodeku, který využívá knihovna GStreamer, nebo je chyba v tom, že kodek neodpovídá zcela specifikaci,​ která je touto knihovnou požadována. Viz. Několik slov o "​nekompatibilních"​ kodecích.
 +  * **Nepodporovaný typ souboru**: Pitivi je určen k editaci videa, proto může pouze importovat video a audio soubory případně soubory s obrázky.
 +  * **Chyby**: Pokud se nejedná o žádnou z výše uvedených chyb, pak se pravděpodobně jedná o chybu v knihovně GStreamer nebo o chybu aplikace Pitivi.
 +
 +<WRAP info> **Tento návod byl sepsán pro Pitivi verze 0.13.4. V novějších verzích se mohou postupy lišit.**</​WRAP>​
 +
 +{{:​info.png}} Součástí aplikace je také přeložená a aktualizovaná příručka uživatele.
 +
 +====== Odkazy ======
 +  * [[http://​www.pitivi.org/​manual/​|Stránky originálního návodu aplikace]] {{:en.png}}
 +  * [[http://​www.pitivi.org/​|Domovská stránka programu Pitivi]] {{:en.png}}
 +  * [[http://​gstreamer.freedesktop.org/​|Domovská stránka knihovny GStreamer]] {{:en.png}}
  • Poslední úprava: 2019/02/25 18:21
  • (upraveno mimo DokuWiki)